易语言-给软件加上时间限制源码

给易语言软件加上时间限制,做一个简单的限制软件使用时间,不是网络验证,想了解网络验证的可以参考我的其它文章,以下是核心代码:

.版本 2
.支持库 spec

.子程序 时间判断
.局部变量 软件时间, 整数型
.局部变量 现在时间, 整数型
.局部变量 月份整理, 文本型
.局部变量 日期整理, 文本型
.局部变量 小时, 文本型
.局部变量 分钟, 文本型

软件时间 = 201208261225  ' 软件使用到期日期
.如果 (取月份 (取现行时间 ()) < 10)
    月份整理 = “0” + 到文本 (取月份 (取现行时间 ()))
.否则
    月份整理 = 到文本 (取月份 (取现行时间 ()))
.如果结束

.如果 (取日 (取现行时间 ()) < 10)
    日期整理 = “0” + 到文本 (取日 (取现行时间 ()))
.否则
    日期整理 = 到文本 (取日 (取现行时间 ()))
.如果结束

.如果 (取小时 (取现行时间 ()) < 10)
    小时 = “0” + 到文本 (取小时 (取现行时间 ()))
.否则
    小时 = 到文本 (取小时 (取现行时间 ()))
.如果结束

.如果 (取分钟 (取现行时间 ()) < 10)
    分钟 = “0” + 到文本 (取分钟 (取现行时间 ()))
.否则
    分钟 = 到文本 (取分钟 (取现行时间 ()))
.如果结束
现在时间 = 到数值 (到文本 (取年份 (取现行时间 ())) + 月份整理 + 日期整理 + 小时 + 分钟)
调试输出 (现在时间)
.如果 (现在时间 < 软件时间)
    _启动窗口.标题 = “软件正常使用中”
.否则
    信息框 (“软件过期”, 0, “提示”)  ' _启动窗口.标题 = “软件已过期”

    销毁 ()

未经允许不得转载:军哥驿站 » 易语言-给软件加上时间限制源码

赞 (0) 打赏

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏