mp3音乐下载 易语言源码

版本 2
.支持库 iext
.支持库 spec

.程序集 窗口程序集_启动窗口
.程序集变量 json解析, 类_json
.程序集变量 下载链接, 文本型

.子程序 _按钮_搜索音乐_被单击
.局部变量 responseText, 文本型
.局部变量 RESUMETHREAD, 文本型
.局部变量 i
.局部变量 Lines


超级列表框_音乐信息.全部删除 ()
responseText = 到文本 (网页_访问 (“http://mp3.runker.net/”, 1, “input=” + 编码_URL编码 (编辑框_音乐框.内容, , 真) + “&filter=name&type=netease&page=1”, , , “X-Requested-With: XMLHttpRequest”, , , , , , , ))
' 调试输出 (responseText)
json解析.解析 (responseText, )
.计次循环首 (10, i)
调试输出 (json解析.取通用属性 (“data[” + 到文本 (i - 1) + “].title”, ))
调试输出 (json解析.取通用属性 (“data[” + 到文本 (i - 1) + “].author”, ))
Lines = 超级列表框_音乐信息.插入表项 (, , , , , )
超级列表框_音乐信息.置标题 (Lines, 0, json解析.取通用属性 (“data[” + 到文本 (i - 1) + “].title”, ))
超级列表框_音乐信息.置标题 (Lines, 1, json解析.取通用属性 (“data[” + 到文本 (i - 1) + “].author”, ))
.计次循环尾 ()

.子程序 _超级列表框_音乐信息_左键单击表项

.如果真 (超级列表框_音乐信息.现行选中项 = -1)
调试输出 (“Text”)
返回 ()
.如果真结束
下载链接 = json解析.取通用属性 (“data[” + 到文本 (超级列表框_音乐信息.现行选中项) + “].url”, )

.子程序 _按钮1_被单击

.如果真 (下载链接 = “”)
信息框 (“请搜索,选一个音乐后继续!”, 0, , )

.如果真结束
.如果真 (通用对话框1.打开 ())
网页_访问 (下载链接, , , , , , , , , , , , )

写到文件 (通用对话框1.文件名, 网页_访问 (下载链接, , , , , , , , , , , , ))
音乐下载

未经允许不得转载:军哥驿站 » mp3音乐下载 易语言源码

赞 (0) 打赏

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏