如何取一个数组前几位成员 易语言源码

易语言数组如何取一个数组前几位成员,当我们把取到的数据放到一个数组里面,然后只想保留前面几位成员数,那么可以参考下面代码:

.版本 2
.支持库 spec

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕
.局部变量 a, 整数型, , "0"
.局部变量 b, 整数型, , "0"
.局部变量 i, 整数型
.局部变量 c, 文本型
.局部变量 x, 整数型
.局部变量 c2, 文本型
.局部变量 d, 文本型

' 数组a={1,2,3,8,4,5,6,7,1,2,3,4,5,6,1,2,3,8,9,8,7,1,2,3},我要找出数组b,数组b的查找方式是从数组a的第一个开始找,1不行,有重复的,然后找1,2.也不行,也有重复的,然后再找123,也不行,也有重复,继续找1238,这个可以,然后找到了以后,判断数组b的第一个数在数组a中的位置,这么说能明白吗,也可以先找1238456,找不到再找123845,找不到再找1238。找不到和找到重复的不算,只找有一个一样的

a = { 1, 2, 3, 8, 4, 5, 6, 7, 1, 2, 3, 4, 5, 6, 1, 2, 3, 8, 9, 8, 7, 1, 2, 3 }

.计次循环首 (取数组成员数 (a), i)

    .判断开始 (取文本长度 (到文本 (a [i])) = 1)

        c = c + “0” + 到文本 (a [i]) + “,”

    .默认
        c = c + 到文本 (a [i]) + “,”
    .判断结束

.计次循环尾 ()

c = 取文本左边 (c, 取文本长度 (c) - 1)  ' 把数组A转成文本型:01,02,03,08,04...

.计次循环首 (取数组成员数 (a), i)

    d = c
    c2 = “”

    .计次循环首 (i, x)

        .判断开始 (取文本长度 (到文本 (a [x])) = 1)

            c2 = c2 + “0” + 到文本 (a [x]) + “,”

        .默认
            c2 = c2 + 到文本 (a [x]) + “,”
        .判断结束

    .计次循环尾 ()

    d = 取文本右边 (d, 取文本长度 (d) - i × 3)

    c2 = 取文本左边 (c2, 取文本长度 (c2) - 1)

    .判断开始 (寻找文本 (d, c2, , 假) = -1)

        输出调试文本 (c2 + “ 未找到重复!”)
        跳出循环 ()

    .默认

    .判断结束

.计次循环尾 ()

.' 变量循环首 (1, , 1, )

.' 变量循环尾 ()

.子程序 _按钮1_被单击
.局部变量 单双a, 文本型
.局部变量 单双b, 文本型
.局部变量 单双c, 文本型
.局部变量 单双d, 文本型
.局部变量 单双x, 整数型
.局部变量 单双y, 整数型
.局部变量 单双j, 整数型


调试输出 (取文本右边 (编辑框_单双走势.内容, 取文本长度 (编辑框_单双走势.内容) - 2))

.计次循环首 (179, 单双x)
    单双a = 取文本左边 (编辑框_单双走势.内容, 单双x × 2)

    .计次循环首 (178, 单双y)
        单双j = 寻找文本 (取文本右边 (编辑框_单双走势.内容, 取文本长度 (编辑框_单双走势.内容) - 2), 单双a, , 假)
    .计次循环尾 ()
    .如果真 (单双j = -1)
        单双a = 取文本左边 (单双a, 取文本长度 (单双a) - 2)
        调试输出 (单双a)
        调试输出 (单双x)
        跳出循环 ()
    .如果真结束
    调试输出 (单双j)
.计次循环尾 ()
单双d = 取文本右边 (取文本左边 (取文本右边 (编辑框_单双走势.内容, 取文本长度 (编辑框_单双走势.内容) - 2), 寻找文本 (取文本右边 (编辑框_单双走势.内容, 取文本长度 (编辑框_单双走势.内容) - 2), 单双a, , 假) - 1), 2)
调试输出 (单双d)

.如果真 (单双d = “单”)
    调试输出 (“双”)
.如果真结束

未经允许不得转载:军哥驿站 » 如何取一个数组前几位成员 易语言源码

赞 (0) 打赏

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏