一个数组是另两个数组删除的结果 易语言源码

当我们需要一个数组的结果是其它两个数组相减后的,就用下面的代码可以解决:

.版本 2
.支持库 spec

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕
.局部变量 a, 整数型, , "0"
.局部变量 b, 整数型, , "0"
.局部变量 i, 整数型
.局部变量 c, 整数型

a = { 1, 2, 3, 4, 5, 6, 7, 8, 9 }
b = { 1, 3, 5, 7 }
c = 1
.计次循环首 (取数组成员数 (a), )
    .计次循环首 (取数组成员数 (b), i)
        .判断开始 (b [i] = a [c])
            删除成员 (b, i, 1)
            删除成员 (a, c, 1)
            c = c - 1

        .默认

        .判断结束

        跳出循环 ()

    .计次循环尾 ()
    c = c + 1
.计次循环尾 ()
调试输出 (a)

未经允许不得转载:军哥驿站 » 一个数组是另两个数组删除的结果 易语言源码

赞 (0) 打赏

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏